Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted Jun 21, 2026 - 19:46 CDT
Update
Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted Jun 21, 2026 - 19:36 CDT
Update
The Minecraft Server is currently under maintenance while we transition over to new hosting and the new Velocity Network. Please check galacticskies.net/discord for updates
Posted Jun 21, 2026 - 19:12 CDT
In progress
The Minecraft Server is currently under maintenance while we transition over to new hosting and the new Velocity Network. Please check galacticskies.net/discord for updates
Posted Jun 21, 2026 - 15:30 CDT
Scheduled
The Minecraft Server will undergo maintenance while we transfer hosts.
Posted Jun 14, 2026 - 10:00 CDT
This scheduled maintenance affects: Minecraft Server and Store.